Waxing the City Website Unavailable

Incident Report for Waxing The City

Resolved

The issue previously impacting the Waxing the City website is resolved and the website functional.
Posted Jul 25, 2026 - 06:36 CDT

Investigating

We are currently investigating an issue affecting the Waxing the City website. The website is temporarily unavailable, and users may be unable to access online content or services.

Our teams are actively working to restore availability. We will provide another update as more information becomes available.
Posted Jul 24, 2026 - 23:41 CDT
This incident affected: Websites (Waxing the City).