Zenoti Mobile POS Checkout Issue

Incident Report for Waxing The City

Identified

We have identified the cause of the issue, and Zenoti is targeting a new app release to address it beginning next week.

We will share updates as more information becomes available
Posted May 08, 2026 - 16:59 CDT

Investigating

We are investigating an issue affecting Zenoti Mobile POS.

Some studios may be unable to complete checkout using the iPad/mobile POS. When selecting Pay, the system may continue loading and prevent the transaction from moving forward.

This appears to be limited to the mobile POS experience. We are actively investigating and will share updates as more information becomes available.
Posted May 05, 2026 - 10:10 CDT
This incident affects: Studio Operations (Zenoti).